SIMULATING WITH

Xilinx Foundation Series

....... it’s just so easy!
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About This Document

This document has extensive cross referencing to pages in the online documentation. If you want to
know how to do ‘such and such” an operation, and haven't yet come across the menu option,
have a look in here . It may point you to the appropriate page in the on-line docs.

Slide 4 outlines the basic simulation process, and is followed by an index to sections 1->4.
Section 5 is a collection of slides that highlight features worth mentioning during a demonstration.

Page numbers to the online documentation are given throughout the presentation. The objective
is to supplement the online documentation, not rewrite it!

Foundation approaches simulation with the analogy of testing a printed circuit board.

W
Each library element and user defined macro is considered as a ‘chip’, to which test signals from
a 1000 channel, 100GHz signal generator can be applied. These signals are test vectors which
can be created and applied to the circuit using some very quick and easy methods.

The output is monitored by a 1000 channel 100Ghz software logic analyzer, and operations such as
Breakpoint analysis and step by step cross point probing with the schematic are implemented with

ease.

To help grasp some ideas of the simulator, try to think of it as a PCB test environment.
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Documents referenced by this “Cheat Sheet”

Extensive reference is made to two sources of online documentation.

1) The Foundation online simulation document \ ACTIVE\ DOC\MANSIM.PDF

2) The online help file \ ACTIVE\ EXE\ xIxguide.hlp

All page numbers refer to the MANSIM.PDF file. It will be useful to have this file loaded into the
Adobe Acrobat reader whilst reading through this document.

To Load the MANSIM.PDF file.......

o Press the icon, in your Foundation Series program group. This will invoke
Adobe Acrobat and load in the ACTIVE\ DOC\ ACTIVE.PDF file.

o Select the Logic Synthesis Book.
o To navigate directly to a page number, double click on the [ mii7ef2as | icon at
the bottom of the Acrobat window. This will bring up a window in which you can

enter the page number.

To load the XLXGUIDE.PDF file........

o Invoke Windows File Manager
o Navigate to \ACTIVE\ EXE
o Double click on xIxguide.hlp
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Contents

There are four basic steps to simulating your design with Foundation:

1)  Creating a logic representation of your design.
2)  Selecting test points for monitoring

3)  Creating and applying design stimulus signals
4)  Analyzing the simulation results.

The following index identifies features associated with each step above.

1) [CREATING A LOGIC REPRESENTATION OF YOUR DESIGN |
-[How do I build a simulation model of my design? |

2) [SELECTING TEST POINTS FOR MONITORING |
From the Schematic Editor |
From the Simulator Waveform Viewer |

3) [CREATING AND APPLYING DESIGN STIMULUS SIGNALS |
-[How do I define my test vectors?|
-IThe Stimulus Selection window |
Software Counter ( Virtual Stimulator)|
Mapping stimulus signals to the  keyboard keys. |
|Describing test vectors using  formulae |

[ Drawing waveforms to input as fest vectors |

[ Viewlogic command files. |

...example ommand 11le
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4) ANALYZING THE SIMULATION RESULTS |

- |[Breakpoints ...... What is one? When would I use one? |
How to create a Breakpoint

- [How to use a Breakpoint |

-|TAGs .. What is one? When would I use one? |

- |ﬂ0w to create a l §§§|

How to use a TAG |

Milestones ....... What is one? When would I use one? How do I create one?
Presets ... Whatis one? When would T use one? How do I create one? |

Selective Simulation What is it?
How to invoke selective simulation |
Cross Point Probing ... What is it?

5) MISCELLANEOUS
- |What do I do if this presentation doesn’t tell me what I want to know? |
- [Topics: - Signal Strengths in the simulator |

- oimulator I"recision
- Changing the simulation ~ short stepand long step duration
- Creating a Busin the Waveform display window
- Zoomingin and out of the waveform display
- Using multiple asynchronous clocks in a simulation
- Simulating Tri-statedevices
-Simulation Modes.  Functional, Timingand Glitch
- Locating simulation data on schematic sheets
- Locating components on schematic sheets
- Running a simulation for hours!
- Backing up data on long simulation runs
- Error reporting
- Resetting the design, what actually happens?
- Tracking Errors through a design netlist
- Annotating measurementsand comments onto the waveform
-|What do the Simulation window Iconsdo? |
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Creating a Logic Representation of the Design
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Creating a Simulation Model to load into the simulator

chematic
) ) %}Editur Er?tlf}r
(A)  From the project manager window
press either of these two buttons. I 1
(If you do not have a back annotated E E:]“gt ﬁmm Z Dﬁ]s;'? !
XNF file, but have requested a timing
simulation, XACT 6 is automatically v + +
launched so that the design can be @ SIM Static {? Prog
implemented). iming {_~Timing| Debug
= Foundation - Schematic Capture - [BOARD1.5CH] EMHE
File Edit Mode Options Hierarchy Yiew Display Window Help | %

sl=[EE[a8] & [mle] N[QE] - [aFde [ <] kR o

o] S B o

(B) Launch the simulator from
the schematic editor by pressing
this button.

Either (A) or (B) will launch the simulator.

. : ” .
Slide 41)is a quick reference chart to the With or without probes: See slide 9

various icons on the simulation window. Select this button and then click on the

net names/ pads/nodes that you are
interested in stimulating and monitoring.
These will be automatically loaded into
the simulator wave viewer window.
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Selecting Test Points For Monitoring
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Selecting Test Points For Monitoring

Loading the simulation window with the signals you wish to stimulate and monitor is as
easy as pointing and clicking.

WHY?
The Foundation Simulator and Schematic Editor are written with software that is OLE v2.0
compliant.

Object Linking Embedded (OLE) v2.0 is a Microsoft standard that defines how data can be
linked between Windows applications. Any changes to the data caused by either application
will be reflected in the other.

The Foundation Schematic Editor and Simulator use OLE to share a common view of selected
signals. This means that signals can be added to the simulation window from the schematic
editor or the simulator, and that the status of every signal in the simulator will always be
back annotated to the Schematic Editor. This cross probing is a VERY useful feature.

HOW?

o From the schematic window tool bar, use this icon, ( Ff| ), to select the probe tool.
Now click on the pads/net names/nodes that you want to display in the simulation window.
A gray box will appear next to the selected item. Launch the simulator using this icon( |£| ).
The waveform viewer now appears with all probed signals loaded into it.

e If it is necessary to view additional signals, these can be added from the simulator and a
gray ‘probe” box will appear on the schematic!  ...see next slide.
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Loading the Waveform Viewer With Signals From the Netlist

Click on the ( &gy ) icon to launch the netlist viewer below. |(see slide 41)|.

=| Component Selection for Waveform Yiewer | "l o
] | Signals Selection | Chip Selection | Scan Hierarchy
MW ¢ a3, A0 B | s sT100 [+

W (BIT?.BITO) = £I101 - OEUF = i '|

A {DECODE3 , DECODE $I102 - OBUF ST - BT CHTY

' CE £I102 - OEUF - -

I CE_IN $I104 - OBUF 7l 5142 - M2 1

1 CLE ESE 1105 — OBUF | 5149 - H2_1

I cLE/ IN $I106 — CBUF (7] 184 - H2 1

1 LEP1 ¥ £I108 — QBUF /

JT 7 3] || E88@ 51113 - IPAD W T 7 +
| | Add | | Close | |§-E§§rmiz:§‘; || Sort by Type | | Info /l |Atlrihutf:s|

This viewer shows a list of nets and buses accessible to/the simulator.

Note that as you navigate the design hierarchy in this window, the available signals
change in this window. To load a net into the simulator wave display , double

click on a signal. A red tick will appear on the signal to indicate that it is now in the
waveform viewer. Alternatively select a group of signals using shift click and drag, then
press the “Add’ button.

The middle window shows all of the library elements at the current level of hierarchy.
Note that chip icons are used to reinforce the idea of the simulation model being a PCB!

(See pg. 106)
SUXILINX"=
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Creating and Applying Design Stimulus Signals

11
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Creating and Applying Design Stimulus Signals

This can be the most tedious of all simulation tasks due to the effort required in defining all of the test vectors used
to emulate real world inputs.

Most PC based Xilinx customers will approach the Foundation simulator with experience of OrCAD or Viewlogic
simulation techniques. The principles are still valid with Foundation, but this software provides a number of
methods to accelerate the simulation and debugging process.

Before the design outputs are analyzed, input test vectors need to be defined. Foundation provides 5 ways of
interactively applying stimulus to the design. The waveform results of these stimuli executed over a number of
clock cycles can be saved as a test vector file. These test vector files can then be used in more complex simulation

processes when invoked by COMMAND FILES and BREAKPOINTS (slide 23).
Each of the following is a quick and easy way to stimulate the inputs of your design.

1) Application of ready made test vectors using the virtual stimulator (pg. 117) & (pg. 19) .
This is a 16 bit software-driven binary counter that counts at a preset clock rate. It is possible to assign any
true/ compliment bit of this counter to any schematic test point so enabling the automatic toggling of the
selected signal line at a fixed rate.

2) Toggling signal lines with keyboard keys  (pg. 117) & (pg. 21)|( slide 15),

Signals in the waveform viewer can be mapped to keys on the keyboard so enabling real time user control.

3) Formulae (pg.120) & (pg.23)|( slide 16).
16 signals in the stimulator selection tool can each be assigned a formula. These can then be mapped to any
signal in the waveform viewer.

4) Drawing test vector waveforms  (pg. 118) |( slide 17).
An editor permits waveforms to be drawn in the waveform viewer window.

5) Using an existing Viewlogic command file (pg- 189). |(slide 18)
The Foundation Simulator will read ViewSim .CMD files because the command language syntax is the same.

S XILINX"—
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The Stimulus Selection Window

This window is used to control how each stimulus signal is created. To invoke the Stimulus Selector,
click on this icon, ([EEE= ), from the Simulation Waveform viewer window.

asynchronous clocks
defined and assigned using

Assign keyboard keys
nodes in your schematic

=| Stimulator Selection

(slide 15) Heyboard:

/tbese buttons.
Clocks:

Constantly running
16 bit counter.

el
w0/0/8/a/0/00E
Iz 310 T T W i ffiead] [Co]CaT

Forces an existing signal waveform to act
/ as an input waveform

True and Compliment

C g 1 0 when assigned to an output
outputs available B 2000 [000d] [0odd][@oad] / if will override the chip generated
(slide 14) NEepo oo oo @oed] [@eed] unction.

FETUE !EHE' HHEH' HEHE' BE

This button displays the current default

= | —" stimulation mode. Click on it and it will
5
_ toggle between 0V and CC (pg.116)

Test vectors defined by /DE] @ @
formula can be assigned

to these LED’s, and in turn 1 fITIM/EI..

/

| |/ Close |
/

assigned to test signals
/
Enables a previously
disabled signal
stimulator.
pg. 116
Disconnects the assigned
stimulator without deleting it.

pg- 116

T
When simulating a bi-directional I/O, a test vector will be applied to the net
connecting the IOPAD output -> IBUF input->OBUFT output. By asserting a
test vector to drive the IBUF input net, the vector signal strength will overrid
the OBUFT output, even when it is enabled.

14°]

Applying this CC key to the test vector that is driving the OBUFT output, will
inform the simulator that when the OBUFT component is enabled, it can driy
the net with the same signal strength as the test vector. When the OBUFT is 1
enabled, the test vector can override the weak Hi-Z OBUFT output state.

So, Use this key when simulating Three-State Functions.

For more detailed description, refer to the on-line help file.

-> Windows File manager, double click omctive/exe/xIxguide.hlp
navigate toFunctional Simulation> Overriding device pins

14

XILINX® =

13



The Stimulator Selection Window : Mapping Signals to The Counter

=| Stimulator Selection File Signal Stimulator W
Heyboard: Glocks: | oo @@@@l

L”-“-”-“|nir‘di‘|‘—'—'—u| Z0ns
o.o ||||||||| ||||||

== 5
=] I ——
[

| _— True

CE_IN. . [e H}-------
U D_IN. |u pqf---mmmmeeeee
| (o N P = EE

el 1
N 1
— ¥
Compliment (| T | —
 Delete | 05 | (ov] DOUTE/ B | R
alovty”. |
|Formula... | | Close | ',.. T

These 32 LED'’s represent the true and compliment outputs of a software drlven 16 bit
binary counter. To quickly assign a toggling stimulus signal to any node in the design:-

a) Click on the signal to be stimulated from the waveform viewer (it turns blue)
b) Click on the counter output you wish to assign to it.
c) Note that the column next to the signal name identifies the source of stimulus.

d) Alternatively click on the LED in the stimulator window and with the left mouse button still depressed,
drag and drop it onto a signal in the waveform viewer.

The above example shows that signal CLK_IN is stimulated by B2 and RST_IN is stimulated
by the compliment of bit 5. (See pg. 117 for further details)

S XILINX”
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The Stimulator Selection Window : Mapping Signals to The Keyboard

=| Stimulator Selection -
File

Signal Stimulator W
Heyboard: Clocks: | 0.6 @@@@l

A A A 2 2 4 4 4 4 WL | ;s iy LLLL Z s
[ L] 4 [1] \b) oo ||||||||||||||||
TR [EEEE |FEEE |EEEE | N T ™ | ——

1
NE:: [@@00] @000 2o @ead) T}%u | S
Form DORE| EEEE| EEEE EEEE] /--TRST_IH. ﬁﬁz -----------------
(&) (@5 ((ee) [ov] 9 c@ﬂ’?w/ A
louTy. | b
|Furmu|a...| | Close | 54. |
d) =

This feature makes full use on the interactive nature of the Foundation software.
Signals selected in the waveform viewer window can be associated with a keyboard key, and
then toggled whilst the simulator is being stepped through a set of test vectors.

a) Click on a signal in the waveform viewer window, (turns blue).
b) Click on a keyboard key in the Stimulator selection window.

¢) The column next to the signal name shows that the selected keyboard key is now mapped to
that signal.

d) Alternatively click on the key in the stimulator window and with the left mouse button still depressed,
drag and drop it onto a signal in the waveform viewer.

e) This column displays the status of the stimulus input. Immediately after making the allocation,
the signal is assigned a Hi-Z state. You will need to press the key once or twice to set a high
strength “1" or 0’ status.

S XILNX"—
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The Stimulator Selection Window :  Applying Formulas
=| Stimulator Selection = Set Stimulator
Heyboard: Clocks:

\
f@'_f@'
(cs )

0
pe: Q00| @@@@' @@@@' 0009|
A EEEEE [EEEREREEE|
F“""'“EHHE' DEnE| ZEEE) | mEEa)

) [ (=) e

|Furmula || Close |

3]

N

a)

d)

Select Stimulator:

stim

stimnlator FO
stimulator F1
\stimulatnr FZ&
}&i.mulatnr F3
stimulator Fd
stimnlator F&

T F&

—1|=stimulator F7
stimulator F2
stimnlator F3

[ [+

™ Mode:
C" Clocks

{® Stimulators

Selected Stimulator:

Formula:

|

I
Asaw F o ; I

i

Defined Assignmentsf
F3, —— - (HIOLG)4fHELE)Z

Cloze

a) To define a formula, press this button to give this window.

b) Double click on one of the 16 stimulator labels.

(The label will turn blue when selected and a cursor will appear in the formula window).

c) Enter the formula and then press Assign Formula. That formula is now mapped to one of the
16 formula buttons in the Stimulator Selection Window.

d) Assign a formula to a signal in the Waveform viewer window by clicking on a signal, and then
clicking on the desired formula button. (See pg. 120->122)

16
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The Stimulator Selection Window :

Drawing Waveforms

wiin| ney did L]

= Foundation - Logic Simulator [
=| File Signal Stimulator “awv Options Patching U
0.0 @@@@I@@@@I@@@@I@@@@H T

a)

d0n= |4I2Ins |6I2Ins |8I2Ins |lIIIIIlns |12IIIJ
o.0 IIII|IIII III|IIIIIIII|IIIIIIII|IIIIIIII|IIIIIIII|IIIIIIII
LCE_IH. . .|= |- =|Tﬂst Yector State Selection [Normal Mode]
igi—iﬂ : ES: A Low High || Unkn_X|[ High Z][ Cnf X
1|RST_IN. .[H5|- ﬁ [; [ S
olouTo. .| |- /ﬁes RBes H ||| Res X ||| Ref ¥ ||| High ¥
o|OUT1. . . . pe || [T T || === || [
ol0UT2 . . .. ~
/[sv L | [sv H [sv % [Ua L [Ua H |
| Cancel Edit Mode || Fast Mode |

a) From the Simulator Waveform Viewer, select EDIT from the WAVEFORM menu.

This will bring up the Test Vector State Selection window.

b) Select a waveform and position the blue cursor to where you want the next waveform

transition to take place

c) Select the state you would like the waveform to assume up to that point, i.e. High, Low, Unknown, etc.

d) Continue to select and draw other input vectors. (See pg. 118 to 120)

17
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Command Files pg. 189

What is a Command File?

A Command file is the equivalent of a DOS batch file in that it will execute a list of instructions
in sequence. In the Foundation environment the command file has a .CMD extension, and each
instruction is known as a macro. A list of macros supported by the Foundation simulator is
discussed on pages 189->227 of the MANSIM.PDF file.

Complex command files can be used to setup the simulator, define clock periods and clocks,
load and save test vector files and check simulation output against known timing files.

In essence, command files are simply a way of driving the simulator in an automated fashion.

It is not essential to use a command file in order to drive the Foundation simulator, but this method
of input is supported because it is an excellent way of scripting a complex simulation process.

Can I use my existing Viewlogic Command File?

YES. Foundation supports the command file syntax used by Viewsim. Consequently
most Viewlogic ‘.CMD’ file statements will be accepted by the Foundation simulator.

Be aware that some Viewsim macros are not supported by the Foundation simulator.
To determine if your Viewsim file contains any macros that are not supported by Foundation, check

pages 195->217.
... more next slide

S XILNX"—
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Command Files

How do I run a command file?

1) Copy an existing command file into your current working design directory.

2) You must now inform the Foundation environment that there is a .CMD file available.
There are two ways to do this;

Either

a) Link the .CMD to the project as described by the bottom four bullet points of page 193.
or

b) Select Ultilities -> Macro -> Edit -> Browse -> select desired .CMD file, then save it.

3) To run the command file select Utilities -> Macro -> Run ->select .CMD file.

..... a window will pop up and display the .CMD file as it is being executed. Any errors or nodes
that could not be found, will be displayed in this window.

TIP! Itis possible to create waveforms using any of the methods defined on slide X.
To turn these waveforms into stimulus test vectors that can be called from a Command file, do the
following.
Select File -> Save Test vectors.... -> Enter a name -> Save.

In your Command file, use the macro “load_timing test_vector_name” to load in the vectors.
(see pg. 224 for a description of this macro). However, note that once you have run a command file, any signal
controlled by the command file will have to be reassigned using the Stimulus Window, | (slide 13), if you wish

to re-engage say keyboard control of the signal.
S XILNX"—
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Example Command File

| Filename calc_fun.cmd. -PGH

| The reset sequence is different from the 3k version.

| This is a sample Viewsim command file. It steps through
| the sequence of commands used in the Calc Viewsim

| Tutorial.

| You can create a command file with any text editor, and

| runitin Viewsim simply by typing the name of the

| file. The default extension is .cmd.

| Echo the command file to the screen, display time
| Re-initialize the circuit
restart

|--mmm e e VECTOR DEFINITION-----------mmmmmmoe

| This file uses the convention that vector names are

| capitalized; this is just a convenience.

| Use the name of the net between the pad and the buffer

| to drive the input at the pad. Net names at lower

| levels of hierarchy are in the format

| ...block_label\block_label\net_label.

| Use "+" to continue a long line

vector SW swl/sw6_p swl/sw5_p swl/sw4_p swl/sw3_p +
swl/sw2_p swl/swl_p swil/sw0_p

| You can also use bus syntax when defining vectors
vector ALU alu[3:0]
vector STACK stack[3:0]

| Set radices for vectors

| The defaultradix is binary for input, hex for output
radix hex SW ALU

radix bin STACK

|--===s=-=-=---SIMULATION OUTPUT DEFINITION--------
| Select the nets and vectors for display in Viewwave. If
| bus syntax is used for nets, nets are still displayed

| individually. If the vector name is used, the value

| of the whole vector is displayed.

wave scalc.wfm clk SW exc_p ALU STACK we rst

| Save simulation values for these nodes
watch clk SW exc_p ALU STACK we rst

| Output the values of all watched signals each time
| "clk" goes high. Create tabular output.
break clk 1 do (print > scalc.tab)

| Output node and vector transitions and simulation time
| whenever any of the nodes or vectors changes state
trace clk SW exc_p ALU STACK we rst > scalc.trc

File = ACTIVE\PROJECTS\CALC5K.CMD

|

clock clk 0 1

| Use a clock period of 100ns. Set stepsize=50ns
step 50ns

| ERCEEEEEE GLOBAL RESET & INITIAL INPUT VALUES----------
| Set initial values for all inputs using the "H" and "L"

| commands for nets and "assign" for vectors

h exc_p

assign SW 00\h

| Initialize all flip-flops (globalreset is active high
| for 5k designs)

| reset

| Viewsim uses units of 0.1 ns, so this statement
| simulates for 100 ns.

sim 1000

h reset

sim 1000

| Exp_p going high is the execute command. OPCODE is a
| three-digit opcode which operates on the DATA. Opcode
| 111 activates an extended instruction set which uses

| the data field as an extended opcode field, as external

| data is notrequired to execute these commands.

| Execute opcode 110 to Load data of 1 to ALU Register
assign SW 61\h

| Set exc_p low with the "L" command

| exc_p

| The cycle command steps forward by one clock cycle
cycle 2

| Execute

| Set exc_p high with the "H" command

h exc_p

cycle 3

| Results: SW=61\h => ALU=1\h STACK=0000

| Opcode 000: Add 13 from Switches to ALU Register
assign SW 0D\h

| exc_p

| You can abbreviate cycle as "c"

c2

| Execute

h exc_p

c3

| Results: SW=0D\h => ALU=E\h STACK=0000

| Opcode 111-101x: Push Register value onto Stack
assign SW 7B\h

| exc_p

c2

| Execute

20
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Analyzing The Simulation Results

21
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Analyzing Simulation Results

Having captured the schematic, invoked the simulator, setup the clock periods and created
test vectors, all that remains is to analyze the waveforms. The designer will know what the

outputs should do for a given set of test vector inputs, but often the difficulty lies in trying to
find out where events occurred, and why.

This next section will cover some of the tools available for debugging with the simulator.

These include;
* Breakpoints
* Tags

e Milestones
* Presets

¢ Selective Simulation

The Simulator also has a method of speeding up the analysis of large designs by using a
process of selective simulation. Components of the design are selectively disabled by the
user, so enabling the simulator to process the reduced design faster.

* Cross Point Probing With The Schematic.

Simulation data is automatically back annotated to the schematic during a simulation run.

S XILNX"—
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BREAKPOINTS

What is a Breakpoint? (pg. 228)

A Breakpoint is a software routine that checks for selected signal conditions in the design.

When these conditions are met, you have reached a breakpoint condition and may perform
the following design operations:

* Stop simulation

e Place a marker on the screen

* Save test vectors

* Load a new test vector file.

* Modify the existing test vectors using the Append operation.

When Would I use a Breakpoint?

Breakpoints are very handy in tracking major design activities and error conditions.
They are used extensively both in hardware tools, (logic analyzers hardware emulators),
and also in software development systems.

Lets say for example that you want to detect a certain value on a bus or selected bits on a bus.
Breakpoint conditions could be defined for each bit of the bus such that when all bits assumed
their respective conditions, the bus breakpoint condition has been met and a marker could

be dropped onto the waveform display.

How Do I invoke a Breakpoint?
See the next slide, for a description of defining a Breakpoint for a bus.
A more complete description can be obtained from the MANSIM.PDF document (pg. 228).

S XILNX"—

23



How to Create A Breakpoint -

1

U1

Tmap pra- ot .:.ulmﬂ— 1) Assign probes to schematic
CoaD . 00 T _TH g_m_ﬂﬂm—.'m DE_DOEN - ol
T ZeD i CLE IN £ O CLOCK - l:lal-'l&""—
T oaD . 8 pa1 m {'." Ea1 RESET - . nOi@AZ |
BILCNT4 | File Signal Stimulator Waveform Options Patching Utiljties
| fins QQOO OO0 0000 @00 /|
= Wa
k-ﬂ |_
www|  zns/div | L | zunT 40ns sl:unT BDnT V/DDTE 1z
. o.o trrrrrerrrrrrrrrrrerrrreirererrrrerrrrerrrrerrrrryrrrebrrrebn
2) Invoke simulator. ke TN, —_—
L[RST_IN. ... .. L e AN
1o_D_IN. .. ... |E 0 i | ieieteleleinisieieluiisisisislsisisinisisin Rttty A
LCLE_IN. ... .. e e e e A
: = = ¥ R e e
-=-| Breakpoint Conditions ME ?.
[T Signals |01 |23 4567 (8|9 |a|b|c|d]|e]|f
ICE_IN. ... .
IRST_IN. ... .. Rl e Rl - | C B .
S A e
1CcIE_IN. ... .. o |
s, A eBus ]
az. ... + A B || | | | | 3) Select
I + ek | el Rl | e - B " T
o ol Eeanes o .
. NS | [ | | | | | Utilities -> Breakpoints

see pg. 229
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How to Create A Breakpoint - 2

=-| Breakpoint States
4) Select the bus (pg. 231) (Lu_w [@-‘ ?nk:n FE:“Z (E&X

5) Enter value on bus that you wish

to detect. (Must be in Hex) — | fiﬂ ﬁ;_*l = (

Bus State

6) To detect the transition to
this value, select Edge.

=2
o
|
=
(=1
7]

7) You have now declared the “mask’ that
/ defines ‘Condition 0'.

'=I \ / Breakpoint Conditions [+ | o 8) IHaVin.g. de’ﬁned a
| |signals [0 [/ (23 4[5(6 7(8[9 a|bc|def Condition’, you must
leg v, ______________ now define the action to
LRSE_IN...... be taken by the simulator
oo e S0 when that Condition is
A
Blaz | (hesiaa Ll Bus met.

AN

Cancel || Click on Edit

...|see next slide |
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The ‘Breakpoint Edit" Window contains
Conditions , (0->F), for which Actions are specified when they occur.

How to Create A Breakpoint -

3

\ Breakpoint Edit
\

:
KME

| I Rt B Y O Y O T O e Y

H —E))
Cornlition

Then

End If

i

Edit...
Check

Conditions

ek

Constructs , ( e.g. If-Then-Else ), which refer to

L

\ 11) Click on Edit and then select an

9) Ensure that this is the Condition you
want to edit.

10) Select a blank line into which an
action is to be defined.

‘Action’.

pd

Instructions-Actions List

e
/ Argument

If
If Elze

W'ait For
W'ait For HOT

Mark Ereakpoint

Save Milestone
Save Test Vectors

Load Mew Test Yectors F
Load Additional Test Weck

Append Test Wectors
Stop Simulation
Delay

Count Time

K

| & Expand

]

Sinnal Bet

4
2

Breakpoint Edit

12) The Breakpoint Action is now defined

PT: 7 [Detete_]
dE Condition O ]
3 Then
4 Mark Breakpoint a
S Ena 1t
__Chﬂ[:k
4
9
t *1[_Cancel ]

Cancel

26

S XILNX"—



How to Create A Breakpoint -

4

Breakpoint Edit

:
KME

2

a

1 If

e Condition 0O

3 Then

4 Save Test vecnggz,Q%ﬂfE
5 Load Mew Test-%ectors Fj
=] mave Milestone

7 Mark Breakpoint

g End If

g If

10 MOT Condition

11 Then

12 mave Milestone

13 Stop Simulation

Credeie

kd
L—1

Edit...
Check

Conditions

i il

Cancel

14 End If

Conditions List

If
If Elze

S

I

Close

13) Note that multiple Actions can
/ p
be defined for each construct,

...and that multiple constructs can be used in
the Breakpoint file.

Each ‘If-Then-Else’ construct is executed in
the sequence in which it is listed in the file.

14) To add extra constructs, double click on an
empty line and make a selection from this box.

Each Breakpoint file can monitor the simulation output looking for the true and compliment of

up to 16 Conditions.

If any one of these conditions occur, the simulator can be forced to execute several actions which
include modifying the current test vector file, saving the status of all signals and halting the

simulation, etc.

This feature is a powerful debugging tool... and it is easy to drive!!

Refer to pages 228 -> 235 for more detail.

27
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How to use a Breakpoint

e == == el s o R

ww|  1onssdiv | L]

|lIIIIIIns |2IIIIIIns I200n= |4IIIIIIns |5IIIIIIns |6IIIIIIns| a0
.o ||||||||| |||||||||

Illllllfllflllllllll IIII|IIII IIII|IIII Illllllja,'l?'llll

Ela3.. . (hex)#4| [El DI E N EE T

1) Load the edited Breakpoint fifé usin

2) Run the simulation. I

tilities -> Breakpoint -> Load -> filename

Breakpoint conditions occur, blue letter markers will be placed on

the display like this.” These letters are the arguments that were assigned to the Set Marker
‘Action” defined when editing the Breakpoint file.

To quickly locate Breakpoints in a large waveform display,

ensure that this button is set to ‘Break’,

=-| /Sl}\pulatur /
*4 \

Break p‘
. Miode: (n]]
!! FH Power

‘J
o R

...... and use these buttons to jump left
and right to the next Breakpoint in that location.

... try it!!

S XILNX"—
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Tags  ps.139
Whatis a TAG?

A TAG is a combination or sequence of signals

When is a TAG used?

Finding a desired signal combination by manually scrolling through the waveform diagram can
be tedious. Using TAGs is a quick and easy way of automatically searching for a particular event
through the whole waveform diagram.

What is the difference between a TAG and a Breakpoint?

BREAKPOINTS operate whilst a simulation is running. They are software routines that monitor
the simulation outputs looking for a particular condition. When that condition is met, they react
as instructed.

TAGS are employed whilst the simulation is stopped, and are a quick and easy way of scrolling
through the waveform looking for a particular condition.

How do I create a TAG?

see|next slide|and also pg. 139.
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How to Create a TAG (pg139)

Waveform Yiey

How do I create a TAG?
e = i e [l sl i
LLLLLLLIJ| lons=/div | I—'—'—U| 100ns |[E00ns [300ns 4|:||:|Ts

|:|.|:| ||||||||| ||||||||| ||||||||| ||||||| thrennjrnia
1) Select Utilities -> View -> TAG a3 .. ... +
This enables a second column next to i i """"" :
the signal names. This column shows an =

the state or transition that each signal tew o H T

contributes to the TAG.

2) Now select Options -> Set TAG Conditions. =| I Set Tag Condition
A state editor window is enabled. Low| High ||| Unkn_x]| High 71| Cnf X
= || == | = | |
Res|L Resz H Res X Ref ¥ High_¥
3) Select a signal from the Waveform Viewer window e (|7 || S [ (== ||
and click on a state in the state Editor Window. S‘U'[_L svh |[ svX uﬂ = uﬂ =
==
. . PP e Bus Busz State
4) To implement a transition, say ‘1’->°0’, = |:|

*select the signal
*select the High state button,

*select the same signal,
e then select the Low state button.

\\&-

The TAG status column should now display a “1’->0" transition.

S XILNX"—
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How to Use a TAG  pg 139

How do I find a TAG?

Waveform Yie

| 1oms/div | L] 100ns [200ns  [200ns | [doods

o.0 ||||||||||||||||||| ||||||||| ||||||| ||||IITIII
A3 ... .. .. +| FAe|rmmommmmm T
&2 . .. ... .. B o oo mpepupayupepupepeyupupupepupepupeynpeyes SRPSPRSS RS
1A, ... .. I I 0 B e peteyepe) syspupupeympupeyuyet TSRSt pupeyepmpepeynyeye SSPRRPPN NP
a0, .. ... ... « L/ =i
1T T - —m—m—m—

1) To quickly find a TAG during any stage of a simulation,
click on this button to until it shows TAG,

=\|\ simulator .
4< w | mr Note that the current time of the
_ simulation is marked in red,

and the TAG cursor that scrolls

around the screen is in blue.
2) ...and use these buttons to jump left or right between TAG’d events.
The screen will jump to a blue cursor that marks the TAG’d event.

S XILNX"—
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Milestones (pg. 152)

What is a milestone?

A milestone is used to store the complete design status that exists at a selected
simulation cycle. This includes the timing at the current simulation cycle, and all internal
registers, memories and flags etc., of all IC models.

When would I use one?

Milestones allow extensive design analysis. You can re-simulate a modified design from a
selected milestone, and request the simulator to automatically display the effect of the latest
design or test vector changes on the selected signal.

It is also convenient to re-simulate the design from a certain cycle with modified test vectors,
new timing delays or other design changes.

How do I create a milestone?

see page 153.
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Presets pg. 127
What is a Preset?

The simulator allows any signal or device pin to be preset to any logical state.

When would I use a Preset?
Preset conditions can be executed at any time during the simulation. Their main use is to test for

some design situation that is difficult to generate, or for a design situation that takes a very long
simulation time to create.

e.g., the end of count sequence on a 64 bit counter takes... a large number of cycles!

An alternative is to set preset the counter to FFFFFFFOh

How do I define a Preset?
Select Utilities -> Selective Preset

This window pops up and you
define the presets as follows.

“i Selective Preset |+ |«
CE_IN. ... | Add.

RST IN. . ... . |l \
U D IH. . .. oo 1) Click on Add in the
CLE_IN. .. ... | —l_Edit... |

AE.? .................... Luad".|

Save...

IR E—
A0

‘Selective Preset’ window

=
M

...see next slide.

____________ e
[Close |

= = = = I~ — — —
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Presets

2) Highlight nodes in

Component Selection for Selective Preset

:
KE

this window, \

| Signals Selection |

Chip Selection

arr

I (a3, 400 +
M (BIT?.BITO)
W (DECCODEZ, DE
I ce
IIr'¥ CE_IN T

TIr

«|

s $I100

£I101
£I102
£I103
£I104

| Scan Hierarchy

v el

o | g |
: CIBT_T [Tl U1 - BI |
[T 5142

+
£l | ad

Selective Preset

:
-1~

3—|’ Add || Close | |§'§§§H’é§¥§:?§ |r

3)Clickon Add —

4) Nodes transferred to here /

5) Select Edit

6) Enter staW
signal.

Then select close.
7) Use Save and LoaN
to choose between

Preset groups.

8) Use Execute to run

Add...

Save...

[Ciose |

the preset.

Low High Unkn High_ || Cnf_X
e || = S

Res L Res H Res X Ref ¥ ||| High ¥
[Lu.u. l’ﬂ'ﬂ'r l’n'n'r [ _____ [——
SY L 5% H S X Ua L Ua_H

see pg.127 to 129
for further details
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Selective Simulation (pg. 56)

Consider what a simulator does.

It operates on a model of the design and tries to calculate what all of the nodes are doing at any
given moment in time for a given set of inputs. Thus it follows that the more nodes that exist in
the design, the more time it takes for the simulator to complete one step of the simulation.

Running a large design for a long simulation period can produce... long simulation times!

More often than not, the simulation is only being carried out to exercise a portion of the overall
design, (e.g. the design is targeted at a XC4013 and just the ABEL state machine needs to be tested.

Why should the simulator engage in calculating the status of nodes that are of no interest during
this particular simulation run?

The answer is that it shouldn’t. The Foundation simulator addresses this situation with a process
called selective simulation (pg. 56)

Selective simulation allows the user to search through the design netlist clicking on icons that
represent hierarchical blocks in the design. These parts of the design are closed down in the
simulation model and their outputs forced to a Hi-Z state. Reducing the number of ‘active’ nodes
in this manner results in faster simulation times.

The process of closing down areas of the design simulation model is no more difficult to achieve
than selecting a file from the Windows File Manager!

...see next slide
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Invoking Selective Simulation

1) Select Waveform Viewer -> Options -> Selective Simulation. .

Note that in any given
hierarchical level, the

..... this window pops up

\

components are symbolized

as ‘chips’.

2) To disable a component, click — ||

on the chip icon, and it

will

change color from gray to

white.

=| Select Chips for Selective Simulation |'| o
"1\5(:an Hierarchy | Chip Selection
L—ds3I70 - CEUF +
el Foot (58 5192 - IBUF
ﬂ EI CHTA4 =g 3193 — RAMIRX1S
T - 83194 — RAMIGRX1S
71 sldz - M2 1 |8 $195 - RAMIGXILS
| 5149 - H 196 — RAM1eH1S
= ~ M2 1 | $I197 — INV
P71 Uz — PATTERNS $198 — INV
199 — IHV
{ 71 — BI_CHT4 =
T2 — PATTEREHS *
«[ I\ -
| Cluﬁ | Sort hszEe | | fnfn \i\|Attrihutt:5|

3) The outputs of selected components

now assume a Hi-Z state in the simulation

/

disabled

model, and this is reflected on the schematic.

4) click on close

...it’s as easy as that!

\

active.
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Cross Point Probing

Due to the Foundation software’s OLE v2.0 compliance, the Schematic Editor and and simulator
tool are very tightly coupled. This enables cross point probing. The status of all probed signals
will be back annotated to the schematic window and the various logic states, represented with

different colors.

Using these buttons, one can advance or
retard the simulator through one clock
transition. The Simulation cursor will
scroll along the Waveform viewer
window, and the annotated signal states,
will change color with each transition.

Similarly, scrolling the waveform viewer cursor along the waveform, will back anngtate the

=|Ei|e Edit Mode Options Hierarchy ¥Yiew Disf

a1 -

= e =] W=Ee |l =z

- IFAD -

- IPAD -

B L 1

SIM e
AR 4 R
2 —+: | STER oo
el |,
| W T, I UF_DvH - ood|—Blgg—— 8.
M CLE_H CLE T . R I
BEST IH EST EESET . . ol _a-— . |
_ . BLCNT4 :*: .

individual signal states to the schematic display.

= \ Wawveform Viey
e = | e\ | e
wu|  1ons/div | L] 100ns  [F00ns Ons | [400dhs
o.n0 |||||||||||||||||||||||||||||| |||||||II‘JIII
&3, ... . ... +| FA|ommmmmmm e\
142, .. ... ... | R e Tty Sy v P >
a1, ... .. .. + | —T
ao. ... o thbr—/r— 1 =i
10T T e ) e ) )
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Miscellaneous

The remainder of this presentation covers miscellaneous aspects of the simulator operation

i.e. - How doIzoom in and out of the waveform display?
- How do I set the clock step size?
- What do all the icons in the waveform display window do?

What do I do if this presentation doesn’t have what I want?

=|Ei|e Edit View Tools Window Help

If you do not find what you are looking for

B

—C[BE [ R

il (1]« [ » [o1][4q]rr

in this presentation, load the MANSIM.PDF /
file into the acrobat reader, ensure this

button is selected, and select the Chapter 1 triangle. =~ —— |
A'long list of topics is presented from which it is

easy to find the subject you are looking for.

Alternatively run the following program by double clicking

on it in the Windows File Manager.

\ACTIVE\ EXE\ xIxguide.hlp

This is the Xilinx Foundation Interface guide

O Logic Simulator
O Preface

== [1 Chapter 1. Simulation Basics

[0 Creating An Electronic Breadboard

[ Selecting Design Test Points

[0 Selecting Test Points In Hierarchical Designs
O Creating Design stimulus Signals

[0 Signal Waveforms and TestYectors

O Ready-Made Sianal Waveforms

[ How Use Ready-Made Stimulators

O kevhoard Keys

O Cwerriding device input pins
[0 Cwerriding device autput pins
[0 Cwerriding net signal narmes

[ Binary Counter

0 Formula Stimulatars

W=

This has many sections specific to Xilinx users.

38
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Reference documents: o A = MANSIM.PDF
o B = /ACTIVE/EXE/xIxguide.pdf

Topics

Signal strengths ..., A (pg.137) &|slide 40

Simulator Precision .......c.cococevererieieninenieceseseeeeseeeeee e A (pg. 46)

Changing the clock ‘short” and ‘long’ step size .......cccccceceveviecvnnennes A (pg. 125) &|slide 42 |

Creating a bus in the waveform display window ...........ccccoeeeeeee. A (pg. 38)

Zooming in and out of the waveform display .......cccccoecncininnnes A (pg. 88)

Using multiple clocks in a simulation ... A (pg. 74)

Simulating Three-state devices B -> Functional Simulation -> Simulating tri-state signals

Simulation Modes Functional . A (pg. 30) &ref. slide 42
Glitch A (pg. 33) &|ref. slide 42
Timing A (pg. 35) &|ref. slide 42

Locating Simulating data on schematic sheets ...........c.cccoceerinenines A (pg. 42)

Locating components on schematic sheets ... A (pg. 42)

Running a simulation for hours! .............cccoccciiiiiniinie, A (pg. 47) & slide 43

Backing up data on long simulation runs ... A (pg. 48)

Error reporting oo, A (pg. 49 & 145)

Resetting the design, what actually happens? ..........cccccoeiiniiniines A (pg. 58)

Tracking Errors through a design netlist ..........cccccooeoiiiiniiinn i A (pg. 79)

Annotating measurements onto the Waveform display .................. A (pg. 138/139) &slide 44
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Signal Strengths that could be observed in the Simulator Waveform Window

State Mame Symbol Descrption

Low e Strong Logical Low state, e g . output ofa TTL gate.

High -_ strong Logical High state, g output ofa TTL gate.

High Impedance — Tr-Gtated output or unconnected inpr.

Unlmowm | Strong Undefined High or Low state, e g . irutial state
ofa TTL flip-flop.

Feastive L ow R Weal Logical Low state, e.g. Open Emitter output in
Low state.

Resstive High TTITTTT Weale Logical High State, e.g. Cpen Collector output
in High state.

Flesistive Unlonowm [ oonon Undefined Fesistive Low or Fesistive High state.

Cutput Conflict RN Indicates that thereis a bus conflict in the node (High
and Lowat the sarne tirme)

High Voltage = Thizlogical stateindicates that thereis a high woltage
atthepin E. g +12V_ -5V, etc. etc.

Feference Voltage e The Feference woltage used in ECL technology

Unlmown Activity Low | commmana Low or B esistive Low or High Impedance This state
iz generated by tri-state ICs when the tri-state control
pinisundefined.

Unlmown Activity High | &= High, Fesstive High or High Impedance, Similar to
the ahowe,

=% High = Power Valtage High{e.g. WCC)

o Lowr s oo Power Valtage Low (e g . GHL

AT — Powrer W dltage Unknown

40
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resetting the simulation using 16 bit software counter LEDs.
Power-On These represent the current
\ / count value
Enable ruler '=| \ Foundation - I,x{git: Simulator [ramtest] [«]«
FI|E ﬁ‘gnal Stimulat Patching Utilities Window Help

Zoom

Displayscale/' ) ||||||||||||||||

=

pg 124

( Note

place cursor in here,
click with left mouse and drag across
the time period then release.

During drag operation a light blue

The Simulation Window (See also pg. 88)

Deletes all waveforms without

(o @@@@I@@@@I@@@@I@@@@H D)

Wawveform Viewer 0 d

Out \ _ B 00 oo -

Ensidiv Z0ns= /J:ltlns 5 = |8Elns \Ll\l:ll:lns |12I2Ins |l4IIlns |lEIIlns |
1 1

ﬂTII I|II IIII|IIIIIIII|IIII

to manually Zoom In,

This invokes the logical states selection window
which allows one to select and assign any logicd
state to any signal or pin. Pg.

—

bar is displayed).

Use this button to toeele th ] This invokes the stimulus window that is used to define
Se this button to toggle the comme and assign stimulators or test vectors to the selected signall

display on and off. See Slide
Comments can be used to document
irflportant situations on th‘f waveforn This invokes the Probes Selection Window which is used to seleff
diagram and can be both displayed at signals and IC pins in the Waveform window. |See Slide 10 ]|.
the specified screen locations and

printed with the waveform diagram.

Toggling this button alternately collapses and expands buses.

Annotates precise measurements
between signal transitions on the
waveform diagram. (pg 138/139)

It is only meaningful only if you have defined some buses, either in the
waveform display window, or applied a probe to a schematic bus.

( See pg. 38)
SIXILNX" =
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Simulator Main Tool Box Window

Toggle this button to select the item to search for.

Breakpoint (pg. 228 &|[slide 23) Presets  (pg. 127 &|[slide 33}
TAGs (pg. 139 &|[slide29) Milestones (pg. 152 &

Errors (pg. 145) Events ...Tqggle these buttons to Search
Launch the Schematic tool =| Xsimulator / / Toggle this button to select between
from the simulator! ah | e | o Simulation modes.
I —_ ] o | e 7"5\ Functional (pg. 30 & 132)
i EW_|| Pouer Glitch (pg. 33 & 133)

'!-.:at.ep ‘I‘zl.u‘r;g m \ Timing (pg. 35 & 133)

Executes a Power On Reset

Run the simulation for a short step (See pg. 58 & 60)

or long step, the periods of which

can be defined like this. (pg. 125) Stop a long simulation.
Note that this button can be disabled.
(see pg. 69 & pg. 64, and[next slide])

To Change the Simulation Long and Short step =| Step
sizes, Select Utilities -> Simulation Step fro

m—t—lji/’,_/_ﬁhmt Step:
Simulators’ Menu Bar. This box appears.

H0ns
un Ste

Select the desired values for each long and short
step, then click on “Set Step’.

.E

Eluse

S XILINX”
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Running a Long Simulation (pg. 64)

The previous slide identified buttons used to invoke a short and long simulation step.

If theidea of writing a Command file to run for hours does not appeal, the simulator has the
ability to define a long simulation period in terms of Hr-Min-Sec.

From the Simulator Waveform Viewer Menu bar, select Options -> Simulation Stop...

... this window appears and it operates as follows;-

/ Define the required simulation

- - period.
This box disables the STOP =| Start Long Simulation A

button on the Simulation Main
Toolbox window. (See Previous

Simulation Running Time: (00: 00 : 15

=

slide). ) - __1— Select this box to enable simulation
) Active Stop Eund“m"%’/ until the end of selected period.
Stop Button im. Till End
This makes coffee. Cancel I

... OK so it doesn’t, but after
selecting it, you can!

If only this worked on my mortgage...
(... This has been a long presentation.)

Note: For simulations longer than 10 seconds, a window
pops up with a display counting down in Hr-Min-Sec.

S XILNX"—
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Annotating Measurements and Comments Onto the Waveform Display

ains QOO0 Q00O 000 000 |

= Wawveform Yiewer 0 - chactive\projects\ramtestistartcnt.tve

L | ZE0ns

W | - Snssdiv ||-|-|-U| E0ns l00ns [150ns  [E00ns [E60ns  [200ms  [3E0ns  |[d00ns  |[450ms  |E00ns  [S50ns  |[600ns  [EEO;
o.n0 IIII|IIII|IIII|IIII|IIII|IIII|IIII|IIII|IIII|IIIIIIII|IIII|IIII|IIII|IIII|IIIIIIII|IIII|IIII|IIII|IIII|IIII|IIII|IIII|IIII|IIII|IIII
BlA3. . (hexiid 5[ I E ! {E [ E fz {1 {0 IF
I[CE_IN. .. .. .. I S | DT TR e e e DL T e ABDEEEEEEFEEEED
I[CLE_IN. . .. .. 111 o e R Setate EEE ettt L ctetetsl SEEE celetele LR ettty R et R ettt e Seletetel SEEE celetetel SRR Sttt e tetetel SEEE celetets IEEE Sl
tlns P Hote thi= 1= an added comment on the waveform
IU_o IN. . .. .. o
I[EST_IN. . . ... T

Measurements pg. 138/139

To activate Measurement annotation, setect ~ Wawveform -> Measurements -> Measurements on.
Use the cursor to drop start points,and endpoints for the measurement annotation.

To Turn Measurement displgy on and off, toggle the ~ Waveform -> Measurements -> Measurements on  option.

Comments pg. 141

To activate Comments, select ~ Waveform -> Comments -> Add , ... add comments in the box that appears, then
select ‘close’. The comments will be dropped where the blue cursor is positioned.

There is no option to hide comments, they are either there or not.
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